IE9 ja eriti kummalised nähtused

  • haavre 9 a

    Teen hetkel ühele USAkale lehte ja sain üllatuse kui vaatasin seda IE9-ga (okei, ma olin halbadeks üllatusteks valmis).
    Lehte saab näha www.dianekappa.com
    Nimelt siis enamusel juhtudest ülemine navigation menu ei tööta, õigemini annab uut lehte avades 404, kuigi leht on reaalselt olemas (kopeerid sama aadressi FF/Chrome/Safarisse ja kõik on bueno).
    Kas on kellelgi ideid, mis sellist anomaaliat põhjustada võib?

    Märgin igaks juhuks ära ka, et kirjutasin juba hostingupakkujale ja küsisin, et ega ei või serveri/konfi kala olla, aga neil pidi kõik korras olema, sain ainult väga asjaliku nõuande tühjendada IE cache ja proovida uuesti.

    Niisiis, ootan ideid, kuidas seda parandada/leida põhjust...

    Tänan.

    17. oktoober 2011 - 20:47:14 · Otselink

  • pane hrefiks # asmele javascript:void(0); või tee kindlaks , et event mis lingi klikkimisel tehakse stopitakse ie9 -l on sellega seoses bugi

    17. oktoober 2011 - 21:03:01 · Otselink

  • paries 9 a

    Kas oled serveri ise häälestanud? Ma vaatasin, et nii Firefoxis kui ka IE-s vastas server 404 (lehte ei leitud), küll aga tuli kaasa sisu, mida siis (peale IE9) brauserid näitasid. IE9 tundub käituvat sellises olukorras ainukesena õigesti :)

    17. oktoober 2011 - 21:09:13 · Otselink

    3

    • mis firefoxi kasutad, mul on endal FFga kõik korrektne (FF 7.01 Mac OS X Lion)

    • Asi pole brauseris, asi on selles, et sinu server vastab päringule koodiga 404.

    Loe kõiki

  • Kui taustal on pattern, siis milleks panna see 1602 × 1063 pildina?

    17. oktoober 2011 - 21:18:27 · Otselink

    2

    • ma tean, et tehnilise poole ja ülesehituse kallal võiks tegelikult pikemaltki võtta. pattern on üsna suure sammuga ning ei andnud vähendada

    • x-teljel on samm täitsa olemas, u 400-450px

    Loe kõiki

  • haavre 9 a

    ei, server on godaddylt võetud, ise pole näppimas käinud.

    vaalaskalale tänud aga, see kahjuks ei toimi sest mõnedel hrefidel on aadress # asemel ja ka need ei tööta. olukorda teeb veel imelikumaks see et mõnel juhul leht siiski laetakse ja 404 ei näidata ja kõik on okei... pole veel suutnud aru saada millest see sõltub.

    17. oktoober 2011 - 22:20:21 · Otselink

    1

    • Välismaa hostingutega olen ise ka alati hädas. Selliseid imeconfe topitakse et tule Command Prompt appi...

    Loe kõiki

  • Allar 9 a

    kui ma võtsin aadressi
    http://www.dianekappa.com/products/fabric/folk-life/
    ja kopisin äsja avatud IE9 aknasse, siis ta teatas, et lehte ei leitud.

    ehk siis probleem ei ole konkreetselt html'is, js'is vaid üks aste enne seda, kui lehe sisu üldse kuvama hakatakse.
    url rewrite, htaccess... jne.

    17. oktoober 2011 - 22:36:20 · Otselink

  • haavre 9 a

    tänan, allar, see kõlab loogilselt, et jama pole niivõrd lehes eneses kui pigem server-side.
    minu jaoks rewrited ja .htaccess on üsna tume maa, oskad midagi täpsemalt öelda, mis sellist käitumist võiks põhjustada ja kas on mul üldse võimalus seda ise muuta või peaksin veidi karmimaid kirju godaddyle saatma (mulle tundus nende vastuse põhjal, et nad eriti probleemi süvenenud polnud esimesel korral).

    17. oktoober 2011 - 22:56:56 · Otselink

  • kui fiddleriga vaadata siis saad sa kõikide brauseritega 404 ja seda juhul, kui su urlide lõpus on / kaldkriips, ilma selleta töötab kõikides browserites. Seega nagu Allar ütlse on viga .htaccessis või rewrite reeglites.

    Kaota kaldkriipsud linkide lõpust või paranda rewrite reeglid

    17. oktoober 2011 - 23:15:28 · Otselink